Fast idle problems - can anyone help? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Fast idle problems - can anyone help?

I've got a fast idle problem on my GTV 2.0. It idles anywhere between 100 and 1500 RPM, never steady and often stalls in the cold.

I've been told this is the stepper motor which sits on the side of the throttle body and looks pretty easy to replace to me (about 140 from Alfa).

The problem is that I've also been told that the ECU needs re-setting after fitting a new stepper motor as the ECU will still try to compensate for the old faulty unit.

Has anyone heard of this or had similar problems?
Sponsored Links
Status: - Update
Posts: n/a
Re: Fast idle problems - can anyone help?

before replacing the motor, disconnect the battery for at least say an hour, this will reset the ECU. The ECU will the 'learn' the new motor.

take pictures while you are doing it. i think mine might be going the same way and would like to know how to do it. do you need to go under the car or what? what side is the motor on?


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fast , idle , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome