Is it the clutch or not - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-06-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2006
Location: penryn cornwall
Posts: 33

Member car:


Help Is it the clutch or not

22nd May had a new clutch slave cylinder fitted by local garage, 8th June can sellect any gears ( wont engage forward gears at all and grinds if trying reverse ) this is with engine running. Turn off engine and all gears are selected ok, start engine and drives but cannot change gear, clutch is also draging slightly. Returned to garage and left car with them, contacted another garage and told clutch bearing has pushed through and new clutch required £590 inc VAT. Same info from local clutch and gearbox workshop. 9th June picked up car fixed? just needed clutch bleeding, seems to work ok, took it to garage that fitted my cambelt last year and guy checked it for me and said looks ok peddle feels right and travel on slave cylinder ok. SO WHY WHEN I DRIVE IT DOES IT FEEL ITS GOING TO BREAK.
I feel like Jenson Button on the last lap (keep hearing noises and feeling somethings wrong) am i going MAD.
FROSTY is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome