water loss/oerhaeating - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-05-10 Thread Starter
Status: -
AO Member
Join Date: May 2009
Location: United Kingdom
County: Kent
Posts: 66

Member car:

***** gtv

water loss/oerhaeating

Hi there,

Not sure what is going on with my GTV, am loosing water and from what i can see it appears to blowing out through the expansion pipe on the expansion tank, also seems to be heating up to 130 odd degrees, which would explain the water leaking, but how is it getting to this temperature in the first place.

I have filled the water up, ran the engine and it climbs to running temperature and then the fan kicks in at just above 90! and it all cool down.

Then after about 100 miles the water has disappeared from the expansion vessel via from what i can the expansion hose. But this dose not happen when i run the engine and keep an eye on the hose.....

bambi1234 is offline  
Sponsored Links
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
only thing which is a long shot, but is the thermostat stuck closed?
itacarboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

loss or oerhaeating , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome