Is the foam pipercross filter bug..ring by MAF? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-05-10 Thread Starter
Status: Alfa's just stop to be admired!
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: Wiltshire
Posts: 217
Images: 1
Idea Is the foam pipercross filter bug..ring by MAF?

Hi Guys, Has a K&N fitted for approx 8 months but decided to change to a pipercross foam one.
The difference is great with less noise but definitely more go.

However, the idle has become pretty lumpy. But touch the loud pedal and she's off like a scalded cat?

Is it the MAF as the pipercross is slightly oiled?
nicklong is offline  
Sponsored Links
Status: burble
AO Silver Member
punt14's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Durham
Posts: 1,925

Member car:

VW Tiguan smoker

My pipercross wasn't oiled when I got it but you get that bottle of spray oil in the box to oil the filter maybe you put to much on
Another thing is mine was running a bit lumpy until a put the filter in the wing now its running great I don't know if you can't do this with gtv but its well worth a try
punt14 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bugring , filter , foam , maf , pipercross

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome