Alarm fault on Spider - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-05-10 Thread Starter
Status: -
AO Member
Join Date: Aug 2009
Location: United Kingdom
County: Lancashire
Posts: 34

Member car:


Hmmm Alarm fault on Spider

The led light on the dash of my Spider flashes all the time and the alarm goes off every time the doors are opened. The battery also drains. Any simple cure would be appreciated
city slicker is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2004
Location: United Kingdom
County: Kent
Posts: 146

Member car:

GTV 3.0 V6

Yep and you're not alone!!!

Click here
Chris_GTV is offline  
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
Does your alarm arm/disarm using your fob? Possibly a dead fob (flat battery). If the LED is flashing all the time it means that the alarm is armed, hence alarm sounding when doors opened!!!!!
Stixy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alarm , fault , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome