Alfa Romeo GTV 3000 Year 2000 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 01-05-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Location: South Africa
County: KwaZulu-Natal
Posts: 24
Boxing Alfa Romeo GTV 3000 Year 2000

Problem Ref not going over 5000 ref help
Alpo Marzoppi is offline  
Sponsored Links
Status: -
AO Member
Join Date: Apr 2010
Location: United Kingdom
County: Norfolk
Posts: 15
hi i had same problem with my 156, fitted new MAF sensor and way hay i was off to the red line, try this first as its cheap and easp to fit (10min) fit this fails then could be a few things but only pluging the lap top in will shorten the list. AUTOLUSSO or ALFA DEALER will identfy fault,(you could then fix fault to save cash) but i have found paying for 1 hour labour to sourse the prob can save lots of trial and error,hope this helps Ian
ilazenbyalfa156 is offline  
Status: OEM'd my rear
AO Silver Member
Freds GTV 2001's Avatar
Join Date: Dec 2008
Location: Australia
County: New South Wales
Posts: 5,223
Images: 48
Most likely MAF

Does it have flat spots in the rev range ?
Freds GTV 2001 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2000 , 3000 , alfa , gtv , romeo , year

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome