Missing manifold bracket - is that a problem? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-04-10 Thread Starter
Status: -
AO Member
RobinHood's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Lincolnshire
Posts: 254

Member car:


Missing manifold bracket - is that a problem?

In an effort to distinguish what's making a noise at high revs I removed the heat shield to hopefully see a cracked manifold bracket.

What I actually found was the tiny remains of the bracket. Only the bit round the nut on the manifold was there??? Maybe someone already removed it - or it fell off. I can't quite see the part bolted to the engine.

Anyway - I guess I have to buy and fit a replacement? Will running without it cause too much stress on the manifold and lead to more problems?

Sorry. One more thing - are there any more brackets to look for?


RobinHood is offline  
Sponsored Links
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
I replaced mine. I work on the 'its there for a reason' mantra. Can't remember the cost now, and I can't look it up at work, but its on my cost list on my project thread in motoring images.
Mitch916 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bracket , manifold , missing , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome