injector light -slow blinking - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-04-10 Thread Starter
Status: -
AO Member
Join Date: Nov 2005
Location: West Yorks
Posts: 60
injector light -slow blinking

Recently my GTV has been doing something weird. After I start the engine the injector light stays on for a few seconds and then goes out. Then a few seconds later it comes back on, and this repeats indefinitely. At the same time there is a noise that sounds like an electric motor coming on and going off. It doesn't happen every time I start the car though. Any ideas?
fivelamps is offline  
Sponsored Links
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
I would get it under diagnostics, it could be any number of things otherwise.
EauRouge is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

blinking , injector , light , slow

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome