Complete Climate Control Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-04-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2008
Posts: 46
Complete Climate Control Failure

Without warning my climate control system has completely stopped working. The aircon LED will not switch on nor can I use the fan/blower automatically or manually.

My first reaction was to check the fuse board under the steering wheel but no blown fuses. Is there a separate fuse somewhere else?

Any ideas??
hlambourn is offline  
Sponsored Links
Status: Back on track
AO Member
Join Date: Sep 2009
Location: United Kingdom
County: Greater Manchester
Posts: 316
There is a resistor pack mounted near the heater motor. Don't know exactly where on the GTV. Mine had gone on the 156 and this gave me the same faults as you. Everything worked fine when I replaced it. If you do a search, a lot of people call it the variable resistor.
kaston is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

climate , complete , control , failure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome