Expansion tank cap fault - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 05-04-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2007
Posts: 725

Member car:

GTV V6 Turbo

Expansion tank cap fault

Hi All

Just thought I'd run this by you all to garner opinion...

During the recent cold weather my car didn't loose any coolant even though it was getting up to regular temperature tootling about. Previous to that I'd had it checked as it was loosing a slight amount - 200mls or so over several weeks. I thought I had this problem nailed but find it's still loosing coolant, but only after I've been stuck in traffic taking it up to 100-105C. Would this point to a faulty expansion cap?


vela blue is offline  
Sponsored Links
Status: -
AO Member
edinburgh75's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Greater London
Posts: 55

Member car:

1998 GTV 2.0TS

i would be concerend if it gets that high ever. Oil can begin to seperate over 115 deg so i would be checking your water pump and fans to be honest.
edinburgh75 is offline  
Status: F year git'n awvahsteer year goan ti farst
AO Silver Member
msgtv's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Derbyshire
Posts: 2,077
Images: 12

Member car:


Just copied this from a post "wot i wrote" yesterday, if you have been driving and then stop in traffic its not uncommon for the termp to rise above 100 deg, thats when the second fan speed cuts in, see below.

Just checked it out, 3.5 miles at 60mph on country roads got to 70 deg from cold, a further 1.5 miles on suburban roads got to 80 deg, on driveway at tick over for 5 mins got to 93 deg, low speed fan cut in,it took the temp down to 90 and then cut out, i then revved it to 2k for 3 mins got to 110deg , the max speed fan cut in, so i recon it's about spot on?

EPSOM 2010
msgtv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cap , expansion , fault , tank

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome