It's all gone quiet :( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-03-10 Thread Starter
Status: Black with red leather :)
AO Member
stjohnsmythe's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: Hertfordshire
Posts: 130
It's all gone quiet :(

Got my V6 GTV back today after having a new oil cooler fitted and some other bits done.

Before I took the car in I noticed that it sounded like there was a slight blow on the exhaust. Turns out that one of the flexi-pipes needed replacing so I had it done.

Now before this it sounded fantastic at high revs and apparantly the reason for this is because the flexi pipe was blowing open basically making the car unsilenced. It has a Regazzon back box fitted which still sounds great but I actually miss the extra noise

Maybe it's time to start looking at additional exhaust options?
stjohnsmythe is offline  
Sponsored Links
Status: 27 Forever!
AO Member
Nath316's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Warwickshire
Posts: 831
Images: 26
drill with a good bit at right point of exhaust a couple of holes later and you have your noise back lol
Nath316 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome