GTV heater fan malfunction - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 19-03-10 Thread Starter
Status: -
Join Date: Mar 2010
Location: United Kingdom
County: Northumberland
Posts: 3
GTV heater fan malfunction

Hi. My first post.
Recently bought a 1998 3.0 gtv - excellent car however the heater fan has a tendency to make an almighty clatter in any position from 1 - 4. It can be temporarily solved by turning the fan to 4 and letting it run. Once it's built up speed it seems to run smoothly on any setting but can be affected by bumps, pot, holes, etc, which cause it it to clatter again.
It seems to me that the fan may be loose but thats just a guess.
Has anyone else experienced this? Is it easy to solve? I don't fancy removing the dashboard!
I had a similar problem on a 156 a few years ago but traded it in before I investigated the problem.
murpherator is offline  
Sponsored Links
Status: AROC 916 Registrar
AO Gold Member
Mitch916's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Kent
Posts: 8,803
Images: 8
You don't have to remove the dash, the fan is in the passenger footwell. Very easy to change and not too expensive secondhand from Autolusso.
Mitch916 is offline  
Status: -
AO Member
dan653's Avatar
Join Date: May 2009
Location: United Kingdom
County: Wiltshire
Posts: 125
Images: 18
Underneath the glovebox theres a cylindrical plastic enclosure, on its underside there's a single nut (6mm?) and a plastic clip. Undo the nut the, then push/pull the clip apart whilst twisting the base of the cylinder and it'll turn about 90 degrees releasing it from the clip and drop right out, then just unplug the electrical connector
dan653 is offline  
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
I had this exact prob with mine, just done as above, removed it, cleaned it all up, re oiled, left it in the house for a day to take the moisture out of it. Been fine since
itacarboy is offline  
(Post Link) post #5 of 5 Old 20-03-10 Thread Starter
Status: -
Join Date: Mar 2010
Location: United Kingdom
County: Northumberland
Posts: 3
Thanks for the advice. I'll have a go next week once i've gotten over Englands defeat this evening!
murpherator is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , gtv , heater , malfunction

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome