another strange revving problem... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-03-10 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: wrexham
Posts: 171
another strange revving problem...

afternoon all, ok, the car is running fine except when i take my foot off the throttle it seems to take a few (too many) seconds to get back to idle hard to explain really without seeing it. sort of a "rev rev....buuuuurrrh(drop a bit)....buuuurrh(drop a bit)....buuuurrh. have had the induction pipes off and all fine. no air leaks that i can find. any ideas?
willis is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2010
Location: United Kingdom
County: -
Posts: 106

Member car:

gtv 2000

Try this it worked for me
Erratic idle speed :.

If the Twin spark engine is NOT idling OK (at about 900 rpm), but
suddenly go to about 1500rpm then down to about 500rpm then jump
between these values a couple of times then back to 900rpm.
The engine might even stall during this.

In most cases, there is an easy 10-minutes cure:

With a screwdriwer you loosen the spanner ring around the airintake-tube
at the point where it connects to the throttle-house.

Pull and bend the black intake-rubbertube a bit to the side and spray some
WD-40 onto the butterfly-valve. Let it work a minute or two, and then wipe
the inside of the throttle-house and the butterfly-valve with a clean cloth.

Oh - yes, you have to use one hand/finger doing the cleaning, and your
other hand/fingers pushing the top of the valve, so it opens and allows
you to clean up the inside. Would be nice with a third hand, though.

The reason for the erattic idle is, that over time the butterfly-valve picks
up dirt in the air-intake-tube. The dirt prevents the valve from completely
closing. The engine therefore gets confused thinking the valve is a bit
open (- thinks, that it is you putting your right foot to the pedal ).

You might have to reposition the idle engine to fix this completely after doing
the above. The way to do that is:
1. Insert key and turn to last position before start. Let it there for 90 seconds.
2. Then turn back off for 90 seconds (with key in).
3. Then start up the engine not using the throttle for a few seconds.

If this is not the cure, you can have a faulty idle speed motor and then
it has to be replaced.

good luck
gary vinten is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

problem , revving , strange

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome