mot drama - car cut out - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-03-10 Thread Starter
Status: -
AO Member
Join Date: Jul 2007
Posts: 725

Member car:

GTV V6 Turbo

mot drama - car cut out

Hi All

This one is a puzzler - car has been running really well. Went for mot the other day and they said it cut out and had run out of petrol. It was fine petrol wise and more got added but it wouldn't fire. No fuel smell either.

I had the crank shaft sensor replaced a couple of months back, but the symptoms were very similar. Mot failed on exhaust leak, rear handbrake even though I'd had all disks and pads replaced and a cracked rear spring. I'd had a pre-check for all this stuff not more than 2 weeks prior, so I was a tad peeved.

Today the garage said it fired up by itself and was fine. Spring is arriving tomorrow and the little jobs sorted. So my question is what else could have caused it not to fire up?


vela blue is offline  
Sponsored Links
Status: -
AO Member
landymm1's Avatar
Join Date: Aug 2007
Location: United Kingdom
County: Devon
Posts: 86
Images: 2
i had a problem like that on a 2.0 GTV it was the wiring to the fuel pump a connector had shorted out and it was a inermitent fault took me a couple of hours to find it too.
landymm1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

car , cut , drama , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome