no ignition lights! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-03-10 Thread Starter
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Warwickshire
Posts: 41

Member car:

2001 cup

no ignition lights!

Help i have took a deposit on my alfa gtv,i put a cd player in for the new owner to be.And sods law it won`t start i thought it was the battery so i charged it but nothing no ignition lights at all any help i would be gratefully recieved as they are hoping to collect this weekend!!
graham long is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2010
Location: Isle of Man
County: -
Posts: 54
I had this problem the other day it is the ignition houseing that has gone down an it is easly fixed if u want u can give me a ring an I will talk u through it if u want I will pm it to u
calster53 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

ignition , lights

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome