Few Bits & Bobs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-03-10 Thread Starter
Status: she's in the garage again!
AO Member
Join Date: May 2008
Location: Ireland
County: Cork
Posts: 80

Member car:

GTV 2.0

Few Bits & Bobs

So I have the GTV nearly two years now and in that times I've....

- Got 1st Service (Filters etc..)
- Replaced (front and rear pads)
- Got a new wing mirror (had to get it sprayed etc.)
- Got a 2nd service (Filters again etc..)
- Replaced Timing Belt, Tensioner & Variator
- Replaced Window Regulator (not cheap!)
- Replaced Brake Hoses
- Radwelled the Radiator
- Repaired Exhaust Manifold
- Replaced Front Wishbones and rear bushings
- Replaced Std Clarion GTV Radio With a Sony
- Replaced Clutch
- Replaced Hyd Slave Cylinder

Wow sounds like a lot (of cash!) when you write it out.
But NOW... here's my problem.
The last job I got done was the Clutch & Slave cylinder
This was done by a good guy who knows his Alfa's
Now I'm not sure if this is a coincidence or maybe the parts just need to bed in but...

Whenever I'm cold starting the car seems to kangaroo jump and has actually cut out
once or twice
. This never happened with the old clutch/slave cylinder.
Is this common with a new clutch?
Should I be concerned?

Fix one things something else always goes wrong
IrishLegend is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

bits , bobs

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome