Metalic noise from either engine or exhuast - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-03-10 Thread Starter
Status: Bugger
AO Member
peter-pan's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Herefordshire
Posts: 167
Images: 7
Metalic noise from either engine or exhuast

Hi all, my V6 seems to have quite a bad metalic noise coming from either the exhuast or the engine at around 3000-4500 RPM recently went in for a new clutch, the flywheel was replaceed as was aprt of the gear box. this noise has appeared since then. any ideas? it's starting to worry me alittle.... well alot really
peter-pan is offline  
Sponsored Links
Status: -
AO Member
nelo1110's Avatar
Join Date: May 2008
Location: United Kingdom
County: Greater London
Posts: 273
One of the heat shields was loose on mine which caused a metalic noise when the engine was at certain revs. Possibly loosened when the work was done on your car? Hope it's nothing more serious
nelo1110 is offline  
Status: leaving
AO Silver Member
neilied's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Cardiff
Posts: 1,055
i have a similar problem after changing flywheel and clutch for gta stock. some point a finger towards ill fitted clutch or shaft bearing.
neilied is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

engine , exhuast , metalic , noise

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome