Hesitation at 3,000 rpm - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Much happier now
AO Member
DangerousDave74's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Nottinghamshire
Posts: 534
could be the injectors?
DangerousDave74 is offline  
Sponsored Links
Status: Replaced Water Pump, All Good.
AO Member
KiwiAlfa156's Avatar
Join Date: Aug 2009
Location: New Zealand
County: Auckland
Posts: 136
You might look at cleaning the injectors either ultrasonically or with an in fuel additive. I've found from expereice that a good quality in tank injector cleaner can make a big difference to flat spots, sometimes eliminating them.
KiwiAlfa156 is offline  
Status: -
AO Member
Join Date: Oct 2010
Location: United Kingdom
County: Wiltshire
Posts: 13
Hello all again,

Changed the spark plugs the weekend as it looked like they hadnt been changed in a while. It runs fine until getting upto running Temp and the hesitation is back.

There is a local garage where I work who read any faults stored for me and it came back with a P1653 fault code which is camshaft postion sensor.

Have I found the holy grail of what is wrong with my car? would this cause said hesitation ?

Also thanks to Smaky for offering to come and read the fault but logistically and time wise it was easier to leave it with these guys for the day get the codes read, but thank you for the kind offer.

Last edited by ilikethembig; 01-11-10 at 17:42.
ilikethembig is offline  
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
Ah! Yours is the cam sensor! Probably damaged by the person who did your last cambelt change? Its a pain of a job to do as you are going to have to remove the cambelt again as the sensor will be on the right hand side cam as you look at engine. Approx 65 part but a new cambelt will be recommended and labour charge??
EauRouge is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

000 , hesitation , rpm

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome