Random Engine Control System Failure warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-02-10 Thread Starter
Status: -
AO Member
andyp1972's Avatar
Join Date: Jan 2010
Location: United Kingdom
County: Greater London
Posts: 79
Images: 28
Random Engine Control System Failure warning light

Hi everyone

The EOBD Yellow warning light on my GTV comes on sometimes (permanently lit).

When its on, its on for the duration of my journey, when its off its also off for the journey duration (i.e. it doesnt flash on and off during the journey).

Have taken it back to the dealer I bought it from (Kinghams of Croydon) and they plugged it into a laptop and said they couldnt find anything wrong with it. Are they telling me that because I bought it from them recently and they dont want to pay out to fix it, or are they telling the truth?

Seeing old posts on here it looks like buying a new battery may resolve the problem.

As per the manual, I have tried "In these conditions, you way continue to drive while avoiding asking a lot from the engine or high speeds" (sic) (Italian Chinglish anyone?)

Is this something serious or just an Alfa electrical annoyance? And will a new battery probably cure it?

As always, I remain gratefully yours in advance of your replies.
andyp1972 is offline  
Sponsored Links
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Kent
Posts: 4

Member car:

147 1.6 ts lusso

i have the same problem on my 52 plate 147 1.6, yellow warning light, car wont start. but if i leave it for a while all is fine starting the car but the yellow engine light is on, when i next start the car the warning light is out. a very annoying intermittant problem , havent had it looked at yet. i am thinking of getting alfadiags to see if i can sort it out myself. good luck sorting your problem out.
igotanalfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

control , engine , failure , light , random , system , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome