front brake problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-02-10 Thread Starter
Status: -
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: Essex
Posts: 38

Member car:

alfa romeo gtv

front brake problems

hi, changed my disc,s a year ago,recently noticed driver front disc only being rubbed by pads on the outer inch of the disc ,removed pad and were wearing unevenly,so new set in still the problem is there,only thing i can think of is calipier not sitting straight, piston is free , not seized, any idea,s
markspark1964 is offline  
Sponsored Links
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
so now you have put a new set of pads it is still wearing unevenly in the same way?

also when you put the new discs and pads on, have you checked the carrier that has to be removed?

are the discs of good quality?
itacarboy is offline  
Status: -
AO Member
jakemate's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Leicestershire
Posts: 173
The caliper is sticking on the sliders, your getting wear piston side but not the other, remove caliper and clean where the other pads slide with a wire brush and lubricate the sliders , this will solve your problem.
jakemate is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

brake , front , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome