Electric Roof not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-02-10 Thread Starter
Status: -
CAMM's Avatar
Join Date: Jul 2009
Location: South Africa
County: Gauteng
Posts: 1
Images: 2

Member car:


Electric Roof not working

Hi all, please can some one assist me, My spider roof does not go down or up,I can only lower or raise the roof if I hold the button in and move it manually. I can hear & feel the motor in the cubby hole, running but nothing happens.
CAMM is offline  
Sponsored Links
Status: waiting for sunshine!
AO Member
Arachnaphile's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Staffordshire
Posts: 61
Same problem with my 2004 Spider. Tried the hammer technique advocated by some....a couple of mothes ago this worked and the roof kept working afterwards. Now when I release the roof latches and press the console button..................nothing, nada, zip !! Tried the hammer thing again but to no avail. I can raise and lower it manually, using the buttons behind the driver's seat but it's a real effort (and doesn't look nearly as cool!) I'm no mechanic so am a little reluctant to dismantle the motor (in the rear cubbyhole, behing the carpet) Also very reluctant to spend 300-400 on a replacement motor!!

I've read that the cause could be:

a) stripped plastic/nylon cog/wheel inside the motor - this apparently can be turned thru 90 degrees and refitted.
b) low hydralic fluid level in the small 'tank' also somewhere behind the seats in the cubbyhole/locker
c) microswitch failure (????)

or d) just cr*p Alfa electrics.............(I also get intermittant 'code' problems that prevent me from starting the engine. Periodically, the little Alfa gremlins decide to go back to work and then they go on strike again....who knows?!)

Still....I was warned that my little mid-life-crisis-weekend-toy-posemobile-tempremental-female-sports-car-thingy would require even deeper pockets than needed to keep the average WAG in shoes...
Oh the joys of Alfa ownership....!

Arachnaphile is offline  
Status: waiting for sunshine!
AO Member
Arachnaphile's Avatar
Join Date: Jul 2009
Location: United Kingdom
County: Staffordshire
Posts: 61
Now I've really gone and done it!!!!! Messing around with the roof etc. and stupidly forgot to disengage the roof latches before trying the motor. Sod's law - the motor decided to work and managed to bend one of the roof struts before I realised my mistake. Now the roof won't fully retract due to the bent strut. Managed to put it back up maually and locked in place. Now I have to find someone who can straighten out the strut and then look at the faulty motor! Bu**er and damnation !!!!!!!!!!!!!!
Arachnaphile is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

electric , roof , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome