brakes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 26-12-09 Thread Starter
Status: -
AO Member
TazzyGTV's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: West Midlands
Posts: 187

phase1 lusso

can anybody tell me if these are meant to have abs? daft question i now, but after spending 150 on new discs and pads at the front, the still dont fee right, i stop good, but when i put that little bit more pressure on, i get a grinding noise and vibration through the pedal, cheers
TazzyGTV is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
yes it should have ABS.
David C is offline  
Status: F year git'n awvahsteer year goan ti farst
AO Silver Member
msgtv's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Derbyshire
Posts: 2,077
Images: 12

Member car:


yes should have abs and vibration through pedal sounds like its working.
msgtv is offline  
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
Easyist way to test is find a suface were there is no grip, ice, snow, feild, hit the brakes if it bangs on your foot it's working,

the yellow abs light comes on the dash when you switch ignition on?
itacarboy is offline  
Status: 100% Alfa Free :(
AO Silver Member
groovylee's Avatar
Join Date: Nov 2009
Location: United Kingdom
County: Bedfordshire
Posts: 4,097
Images: 77

Member car:

A Motorbike ;)

tazzy, the symptoms you give are exactly the same as i get when the abs cuts in, as i found out lots in the snow and ice, so i would say all is well. i think that every one should test their abs when getting a new car, and maybe once every now and again so there are no surprises when you need it! i have heard of people braking hard, then when the abs (that they knew nothing about) feeds back through the pedal, they let off the brakes because they think something is wrong and then susequently crash
groovylee is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Yep I'm with most people here and reckon your ABS is working as advertised.
Nige005 is offline  
Status: -
AO Member
Wabby's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Lincolnshire
Posts: 200
Images: 3

Sounds like its working
Wabby is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome