Hunting at minimum throttle at cruising speed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-12-09 Thread Starter
Status: -
AO Member
gooman's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Bedfordshire
Posts: 469
Hunting at minimum throttle at cruising speed

Not the normal idle speed problem ...

Since switching to Shell V-Power and having a generally much more responsive engine, I've noticed something odd when cruising at speed.

I can now maintain 50mph or even 70mph on the flat with almost minimum throttle - my foot is barely touching the accelerator.

But the car lurches slightly when doing this. If I accelerate or decelerate it's smooth, it's only when maintaining cruising speed with a light touch that I get the problem.

Any suggestions as to what I should check out?

I have got a slightly blowy exhaust (which needs fixing ASAP) - could that be something to do with it?
gooman is offline  
Sponsored Links
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
it is possible as the flow of gases is not smooth, but i would say could be more of a fueling issue
itacarboy is offline  
Status: -
AO Member
jakemate's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Leicestershire
Posts: 173
If you have a blowing exhaust between manifold and cat then the lambda sensor may give incorrect reading hence a fuelling problem.
If you have a second lambda after the cat make sure its not blowing before there also, in fact, sort the blowing exhaust out
jakemate is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cruising , hunting , minimum , speed , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome