Factory Fitted Alarm issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 24-11-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Posts: 15

Member car:

Alfa Romeo GTV

Factory Fitted Alarm issues

Alfa GTV 1999 2.0

Please help!! I went to my car this morning to find the battery had died, on replacing the battery the alarm will now not switch off, unfortunately I haven't had a fob for years as it broke! I have no idea what to do. I spoke with an auto electricioan who said he could take a look but doesn't hold out much hope of removing the alar. What can I do??!!!
wezdance is offline  
Sponsored Links
Status: -
AO Member
dazgtv's Avatar
Join Date: May 2009
Location: United Kingdom
County: South Yorkshire
Posts: 109
I had the same problem

Go in the passenger footwell, undo the 2 screws of the panel to the left of the stereo. pull it off and you can access all the wiring behind the stereo. There is a black box the size of aprox 2 cigarette packets among the wiring. A few are different i believe but mine said fiat meta alarm system on it, pulled out the wires from it and it hasnt bugged me since.

Hope that helps
dazgtv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alarm , factory , fitted , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome