GTV V6 Broke down, starts then cuts out instantly - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-10-09 Thread Starter
Status: -
AO Member
javars's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Somerset
Posts: 337
GTV V6 Broke down, starts then cuts out instantly

About 2 weeks ago, My GTv V6 cut out on the motorway slip road with no warning. It would then restart but cut out instantly as if it had no fuel pressure.
I had to be recovered by the RAC and I left it with my local trusted garage and went on holiday.
After a lot of f4nnying about, gues what it was ?
Yes the MAF !!
All of the diag equipment suggested there was no problem and even disconnecting it wouldnt let it run. The fault code that kept coming up was the immobilisor circuit.
So there we are. Hope this thread is usefull for anyone in the future.
javars is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

broke , cuts , gtv , instantly , starts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome