Does your GTV whine? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Tired of waiting!
AO Member
gogsygtv's Avatar
Join Date: Feb 2010
Location: United Kingdom
County: Glasgow
Posts: 72
Images: 22

Member car:

159 Ti 1.9

My 145 Cloverleaf had a supercharger-esque whine, it had a K&N 57i induction kit on it though and also had matching air sucking noises. Was always commented on by folks when they were in it.

Later the same kit which had been salvaged from that car was fitted to a 155 2.0TS and it had the same effect.

No such whining from the V6, just a milanese roar
gogsygtv is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Mar 2005
Location: Leeds England
Posts: 2,220

Member car:

GTV V6, ex 166er

Only the wife......
CrispDust is offline  
Status: 0.9 turbo power....
AO Silver Member
p17sut's Avatar
Join Date: Nov 2004
Location: United Kingdom
County: Fife
Posts: 3,221
Images: 33

Member car:

500 twinair

Originally Posted by EauRouge View Post
Recently developed the same whine! and from what you guys are saying ie: you replaced all the belts, tensioners & idlers and the whine persisted! Would i be right in saying that the problem is most likely to be the Power Steering pump as the whine increases and decreases with engine speed?

ER, I bought that car and it was the alternator that caused the whine.
I posted about resolving the problem in another thread fairly recently.
p17sut is offline  
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
Originally Posted by p17sut View Post
ER, I bought that car and it was the alternator that caused the whine.
I posted about resolving the problem in another thread fairly recently.
I shall search for your post now p17sut! many thanks! I reckon my whine is coming from the front of the engine at least i hope so as i do not fancy replacing the alternator
EauRouge is offline  
Status: Goodbye bella...
AO Member
Scheimann's Avatar
Join Date: May 2008
Location: United Kingdom
County: Berkshire
Posts: 192
Images: 18

Member car:

GTV 2.0

Mine's like a woman - sometime it moans constantly and for no apparent reason, other times it doesn't moan for weeks. I don't think it would be the power steering pump, and it would only make a noise when you're turning.

I think mine is my clutch or thrust bearing - i will get round to changing it one of these days and let you know if it helps.

Mine appears most regularly around 4000rpm and sounds like: a balloon releasing air really fast, or a cat trapped in my glovebox and meowing really loudly and passionately. It drives me nuts sometimes!

FITTED: discs (F), Ferodo pads, thermostat, front wishbones, condenser, MAF, Brembo discs (R), Falken tyres

"Because Alfas have flaws, they feel human, as if they have a soul and a temper. Each one is like the tortured hero of a Russian novel, a car you can never truly fathom, especially when it is 4 in the morning and it is enveloped in a cloud of steam, yet again, on the North Circular."
Jeremy Clarkson
Scheimann is offline  
Status: -
AO Member
Join Date: Nov 2009
Location: United Kingdom
County: Somerset
Posts: 45

Member car:


alternator whine

Mine does, its the alternator bearing.. but having read about what a pita it is to change out, im going to wait for it to die.
shouldbworking is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , whine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome