Heater Fun - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-10-09 Thread Starter
Status: MOT killed MAF
AO Member
Join Date: Oct 2009
Location: United Kingdom
County: West Sussex
Posts: 67

Member car:

3.0 GTV

Heater Fun

Hi All

Any clues on this one:

Heater only works after 24 on the dial; its cold upto this point. It did work once, then I accelerated rather hard and then air turned instanly cold!


steves916 is offline  
Sponsored Links
Status: -
AO Member
james964's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 14

Member car:

156 2.5 v6

anyone? im getting the same problem too!
james964 is offline  
Status: - Update
Posts: n/a
its all electronically operated,so im guessing that its just not switching the temps over,cant be any more help other than that im afraid!! Although if your water temp guage is showing low temps you might have a stuck open thermostat,making it not heat up properly. Is the air hot after 24 or just warm?if its warm then i would say your thermo is open but if its hot then you need to talk to someone regarding the electrocnics of that switch!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fun , heater

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome