sump plug thread - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 26-09-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2008
Location: United Kingdom
County: Surrey
Posts: 10

Member car:

GTV 2.0

sump plug thread

Got me a 2.0 GTV the other week and a very lovely thing it is too.

first job was to change the oil... all going well until i tried to do the sump plug up and... it kept on turning. the thread in the sump is damaged and i see on the forum i am not alone!

anyhow the bolt only went loose at the very end so i cleaned up the old washer and put two washers on the bolt. it now tightens to the correct torque and doesn't appear to be leaking.

my question is do i drive straight to my nearest garage and ask them to sort out the dodgy thread or is it fixed for now so i can leave it until the next oil change?

i've got a few long trips coming up soon and don't want to take any chances.

Any thoughts much appreciated.

neil182 is offline  
Sponsored Links
Status: #keepFightingMichael
AO Gold Member
EauRouge's Avatar
Join Date: Jun 2009
Location: Suriname
County: Brokopondo
Posts: 7,568
Images: 12
If its torqued it should be ok? The big problem with many is they do not put on a new washer! However! as you say it is well known problem so i would watch it for a day or 2 to see if you have any oil below where you park!

You can also helicoil it with the kit!
EauRouge is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
you might have been lucky and actually reformed the thread, dont forget the sump is alloy but the plug is mild steel.
Durty dog is offline  
Status: -
AO Silver Member
armoore's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 3,690
Or try for a timesert (do a google search) instead.
armoore is offline  
Status: Always working
Identity Confirmed
Authorised Trader
Autolusso's Avatar
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 6,231
Images: 222
We have has some steel inserts made to fix this problem, we drill the hole out bigger and screw in the insert then the original sump plug in so the problem never happens again.

We charge 80 to fit one, this includes an oil and filter change

All the best

Autolusso is offline  
Status: Thinking of what Alfa to buy next!
AO Silver Member
GTV Bertone's Avatar
Join Date: Mar 2005
Location: United Kingdom
County: Greater London
Posts: 1,096

Member car:

Alfa GT 1.9 JTDm

When i had the same problem on TS gtv, i think my specialist helicoiled it.
GTV Bertone is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

plug , sump , thread

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome