Alternator issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-09-09 Thread Starter
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
Alternator issues

hi guys

on my gtv it has a recent new battery so i charged it up and it had 13.6v

wen the car is running the battery only is reading 12.6 ish.

normally cars run around the 14v ish

so i am thinking my alternator is nakerd, as it will not charge the battery no matter how high or low the revs are.

but the car is a 2001 with 77k on it and there is no signs of alternator sqeeling or rumbleing,

any other tests i could do before i replace the unit?

itacarboy is offline  
Sponsored Links
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
Sounds to me that your alternator is on it's last legs, could be a dirty/corroded connector on the alternator leads??
Stixy is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,082
Images: 22
Yep, should get a little over 14 Volts with the engine running, you are not getting a charge. First things first of course check all connections for cleanliness and security, don't forget Earth Straps. Of course ensure that the Alternator drive belt isn't slipping/loose.

Perhaps it is possible to check the Alternator output on the connection on the Alternator itself, never done this so I'm not sure. A good auto 'leccy should be able to tell you.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alternator , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome