GTV Wont Idle - A Little Help? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-09-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: -
Posts: 23

Member car:

GTV 2.0

GTV Wont Idle - A Little Help?

Hi Guys

I nearly had my gtv perfect and running, until tonight!

I have just finished fitting a cat 1 alarm to it, all was working fine. The only immobilisation circuit I was using was the fuel pump wire.

I was trying the anti hijack feature for the first time today, it worked, but then the car refused to idle after this. It will start, but only with a tiny bit of throttle. It also drives ok right through the revs, no hesitation, no stuttering, it just refuses to bloody idle and conks out!

Now then, I immediately thought it was the alarm at fault so reconnected the wire that I had initially chopped to put through the immobiliser module, but much to my it still refused to idle.

Ive tried the fuel cut off switch, no luck there.

My idle control valve on the TB makes a clicking / buzzing, could this be the problem and its just a coincidence?

I have disconnected the battery for the night, hoping that it will fix its self by the morning!

Any suggestions would be much appreciated, I had it booked in for an MOT tomorrow morning after a 6 month tart up and re engine, not amused!


ugp is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , idle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome