Radio install - won't lock in place - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 04-09-09 Thread Starter
Status: -
AO Member
gooman's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Bedfordshire
Posts: 469
Radio install - won't lock in place

Similar issue at the beginning of the "Radio Nightmare" post - though I've not had any subsequent electrical problems.

I can't slide my new head unit all the way in. I'm not sure if it's due to wires getting caught, or if it's due to the large heatsink on the back.

Did anyone else run into this? Any solutions?

gooman is offline  
Sponsored Links
Status: Itchy modding fingers...
AO Member
darkangelv2's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: Hampshire
Posts: 263
First thing to do is measure your head unit front to back then measure the available depth to the flat piece of metal that sits behind the headunit in the car. If these measurements stack up as mine did then.....

I found with mine it was a LOT easier with the gear lever surround removed as this gives you a way to get your hand to the rear of the head unit as you feed it in. You can then guide the wires into a gap and not squash them into the supporting flat piece of metal.

However, you should be very careful if removing the lever surround as these are notoriously delicate at the rounded corners where the leather is held in. It's an idea once you have it out to brace it with duct tape to try and add strength.
darkangelv2 is offline  
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
Remove the side panel on the centre cosole and look to see what is stopping the headunit sliding back fully.
Stixy is offline  
Status: -
AO Member
GTVDAN's Avatar
Join Date: Apr 2007
County: -
Posts: 381

Member car:


Originally Posted by Stixy View Post
Remove the side panel on the centre cosole and look to see what is stopping the headunit sliding back fully.
What he said, I thought my head unit was too big, it was just the wires bunched up. Theres 2 holes at the rear left and right, and you can pull the wires through. Problem solved
GTVDAN is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

install , lock , place , radio

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome