3.0 Water Pump Question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-08-09 Thread Starter
Status: -
AO Member
Alan Walker's Avatar
Join Date: Apr 2006
Location: United Kingdom
County: Devon
Posts: 389
Help 3.0 Water Pump Question


I'm having a new cambelt and clutch fitted to my late 2002 GTV 3.0 with 55,000 miles. I've asked the garage to change the water pump as a precautionary measure but I'm wondering if this is actually necessary as it has the metal impellor. Any advice gratefully received.


Last edited by Alan Walker; 26-08-09 at 17:30.
Alan Walker is offline  
Sponsored Links
Status: GTA Tiiiiiiiiiime!
AO Silver Member
JR Racing's Avatar
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 1,573
Images: 5
If it is the 3.0 block it should have the metal impellor and as a precaution it should not need to be changed.

It is the later 3.2 engine that has the plastic impellor along with the TS models.
JR Racing is offline  
Status: Confused
AO Member
Join Date: Apr 2008
Location: United Kingdom
County: Surrey
Posts: 74
And for what it's worth, mine was replaced at 7 yrs / 49K, metal impellor was OK but the bearing sh***ed.
For the additional cost I'd replace it.
MURPHSDAD is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

pump , question , water

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome