Emissions MOT failed with Ragazzon and induction - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 13-08-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: Somerset
Posts: 76
Emissions MOT failed with Ragazzon and induction


My car has just failed its MOT on emissions aswell as a number of other things. I have a Ragazzon exhaust on the back, which is straight through removing the last 2 silencers. Then there is the standard transverse silencer before that, and from there to the engine is a stainless steel exhaust with new CAT up to the front pipe. Also an induction kit.
Have reviewed other threads about the Ragazzon effecting emissions and it appears it doesnt.

Could it be the CAT (which was made with the custom exhaust) or the induction kit causing it to fail? (the sensors are all still present with the induction kit fitted)

Or could it ba a sensor fault? The CO results were:

Fast idle - 7.972 (limit 0.3)
2nd fast idle - 6.973 (limit 0.3)
Natural idle - 8.140 (limit 0.5)

How would I check if a sensor is working without buying a new one and fitting it? I see a lamda sensor alone sells for between 30 and 40.

Any help would be greatly appreciated.
lowthergtv is offline  
Sponsored Links
Status: fix it till it's broken
AO Member
Black-Sheep's Avatar
Join Date: Jul 2008
Location: Germany
County: Sachsen
Posts: 562

Member car:

Delta III 1.9 TT


Lambda can be checked with the Alfa Diagnosis Tool the Dealers have.
Plug the thing in, and then take a look at the lambdadata (engine has to run! > Live signal), mine was fragged to there was no signal from it started with some 7 Volts and went to 0.0 so no lambda regulation at all (Failed Emissions Test due to this too )
Black-Sheep is offline  
Status: -
AO Silver Member
Markos's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: Greater London
Posts: 1,280
Images: 5

Member car:


At the MOT have the car as warmed up as possible. The tester will rev the car to around 3k rpm iirc, but if that doesn't work tell them to take it higher to 4k rpm, then watch the emissions fall quickly
Markos is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

emissions , failed , induction , mot , ragazzon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome