cambelt, am i being over cautious? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Always working
Identity Confirmed
Authorised Trader
Autolusso's Avatar
Join Date: Feb 2007
Location: United Kingdom
County: Bedfordshire
Posts: 6,241
Images: 222
Originally Posted by jamesy View Post
I agree that the TS is known for snapping cambelts, I have owned three without any problems (so far) I actually change the oil and filter every six months it just seems crazy that I should have to go to that expense after 3 years and 8k miles for peace of mind
Twin Sparks

I will give you three recent examples we have seen at my place

1. Alfa 156 2.0 @ 120k – 66k since the last belt change, on changing the belt it had original factory idler and tensioner, how was this car still running?
2. Alfa Spider 10 years old and 45k, never had a belt change
3. Alfa 147 1.6 – 3 year 2 months 26k – belt snap

It is so difficult on how to advise people, the problem comes for us is if we say “don’t worry it will be fine save your money” and it breaks we are responsible for bad advice

Autolusso is offline  
Sponsored Links
Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,575
Images: 13
The belt rubber does deteriorate with age, plus a belt is under most load at a cold start and lower mileage cars tend to have more of those.
symon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cambelt , cautious

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome