New MAF but still problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-07-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2008
Location: Cheshire
Posts: 61

Member car:

GTV 3.0 V6

New MAF but still problems

I recently had a problem with my MAF and replaced it with a genuine BOSCH one from Emissioncontrols. At the same time I replaced the air filter (as the previous one was the TS one and not the correct V6). I then went through the ECU reset procedure and for a week or so all was well.

Tonight on the way home after ~30mins it started to be really hesitant on acceleration and then the spark plug warning light came on. The hesitancy was consistent in all gears - I would change gear and accelerate - the car would take a second to think about it and then respond. The idle also appears to be a little variable and felt pretty low.

When I came home I stopped it and left it for a while. When I started it up again the light went out.

Any ideas what it could be? Should I be worried about a breakdown coming?
Kuwooli is offline  
Sponsored Links
Status: at the petrol pump!
AO Member
greg172's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Angus
Posts: 484

Member car:

gtv v6 & 159 ti

u had the same problem i had when my car was eating air flow meters i discovered it was a ts air filter causing the trouble. i havent had any problem since but all i can suggest is checking the whole air intake system checking for any dirt or debri that maybe effecting the air flow. if the car is hesitant when u put ur foot down id be 99% sure its a related problem.
greg172 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

maf , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome