Soft top stuck - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-11-03 Thread Starter
Status: -
AO Member
Join Date: Jun 2003
Location: Trelleborg, Sweden
Posts: 80
Soft top stuck

The central button on the mid console blinks red when starting car - showing that there is a fault with the hood.

Sure enough I cannot open the hood on this button - I have to first go to the main buttons behind the seat to release the hood catch ( I think ). After this you can use the central switch again.
Closing the hood appears not to be a problem.

The handbook says go to the dealer with the problem. My dealer could not even find the extra switches - no chance there.

Help anyone ??
swedespider is offline  
Sponsored Links
Status: -
AO Member
Join Date: Oct 2003
Location: United Kingdom
County: Cornwall
Posts: 11
You're not alone! Mine does this when I've not used the hood for a while. Once I've used the manual buttons to open the hood it works again - pretty annoying. It's due for a service soon so It'll be sorted then hopefully. Alfa reckon its due to dirt getting in the hood anchors at the rear causing friction - I reckon it's dodgy elcetrics! Hope you solve it!
ian r is offline  
(Post Link) post #3 of 3 Old 14-11-03 Thread Starter
Status: -
AO Member
Join Date: Jun 2003
Location: Trelleborg, Sweden
Posts: 80
You actually touched on a nerve. When first delivered the release didn“t always work - I had to put a hand on the roof to help the release - I told the dealer. After I got the car back he explained he had "greased " in the threads.

Now I am thinking these threads should not have been greased, but oiled. Like your dirt - the grease may increase the friction, depending upon which type he used.
So this weekend I am going to try to degrease and oil instead.

Incidently mine does not clear any more - it is permanently out.

swedespider is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

soft , stuck , top

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome