Intermittent wipe-gone wrong!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Intermittent wipe-gone wrong!!

My intermittent wipe mode stops at the wrong position every other sweep - ie. halfway across the screen!! This problem first occurred about a year ago, then earlier this year around late spring the problem disappeared but now it's back.
I reckon it might be related to cold weather or moisture ie. expansion/contraction on some electro circuit somewhere.
Took it to the dealer & he says need new wiper motor which comes as the whole wiper assembly mechanism at 350+vat!!
Anyone know if there is an alternative to this such as possibly an auto electrician repairing the circuitry etc??
Sponsored Links
Bill Earlam
Status: - Update
Posts: n/a
I hate to say it, but they're pretty much right.

You could fit it yourself and save 100. I did mine in about an hour.

Out of interest I took the old one apart. there's a disc on the back of the capstan box with contact tracks on it that seemed to be clogged up with too much grease, so maybe an auto - electrician could get it sorted, but you ned to de-solder 3 contacts to get at it and then put it all back together again with the correct alignment.

It may be wiser to buy the new one and then you know it should last a few years. If you took it to an auto-electrician you'd be wondering how long it'd last....
Status: - Update
Posts: n/a
This was the first problem I had too.. got it done on the warranty (used Lumley thingie.. but seem to remember there were quite a few posts on this - ideas of just cleaning up the contacts seem to work for some..
Status: - Update
Posts: n/a
just for informational purposes the windscreen wiper motor cost me 420 inc vat and installation.
Status: Daddy bear
Global Mod Team
bazza's Avatar
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 42,042
Images: 3

Member car:

Alfa 156 GTA SW

eek! Holy crap! eek!
I think I need to lie down now. I just spat Coke all over my computer screen too frown
bazza is offline  
Status: - Update
Posts: n/a
Hmmm mine has started doing this occasionally...Is there anything I can do to prolong the life of the motor? Or, am I on the long road to 400?
Status: Alfa 159Ti with bodykit
AO Member
Troll's Avatar
Join Date: Aug 2003
Location: Swindon, United Kingdom
County: Wiltshire
Posts: 869
Images: 2
ouch, my missus wiper motor stops a 1/3 up the screen after a few wipes... but I think we will be taking it apart as she is a demon solderer !!

Will let u know if it works !

Troll is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

intermittent , wipegone , wrong

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome