Help, my fan doesn't work - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-07-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: Leicestershire
Posts: 11

Member car:

2000 GTV

Help, my fan doesn't work

Right I brought a GTV with a non working fan, I have wired it up so the fan can be turned on and off by popping the bonnet and connecting two wires but i need a real solution.

I have done some investigating, the fuse is fine. I have power getting to the fan. and the fan does work. It has something to do with the earth side of things. I have traced the earth back into the loom then up to the bulk head but from there I am lost. Any body got any clues?

Also when looking at the fuse box one of the relays is missing, E10 if memory serves me correct? does that hold the key?

regards, Dan

edit* it is a W reg GTV t-spark p2
bourneyo is offline  
Sponsored Links
Status: -
Join Date: Mar 2009
Location: I would rather not say
County: -
Posts: 106
hi mate, your problems i think lie in your fan resistor located alongside your fan on the rad. held in by 2 screws. i bet if you remove them the resistor wouldve fallen off or be corroded. that kills the whole relay.

ive got a spare one you can have cheap if that is the issue. but it was with mine

hopoe you get it sorted
john_rdy is offline  
Status: -
AO Member
jakemate's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Leicestershire
Posts: 173
Yes, there are two load resistors on mine dan, thats where my bad connections and melted wiring was coming from.
Take em out and check connections.
jakemate is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fan , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome