Is the Electric Aerial fused somewhere? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-07-09 Thread Starter
Status: -
AO Member
williamsdad's Avatar
Join Date: Jan 2008
Location: United Kingdom
County: Hampshire
Posts: 109
Is the Electric Aerial fused somewhere?

My Electric Aerial stopped working a while back so I bought a replacement from Maplins and fitted it this weekend. Its all hooked up correctly but refuses to work, it looks like theres no power going to it ... does anyone know if the power supply for the aerial is fused somewhere? i'm thinking it'd be just my luck that a fuse has gone somewhere and i didnt need to change the aerial at all !
williamsdad is offline  
Sponsored Links
Status: GTA Tiiiiiiiiiime!
AO Silver Member
JR Racing's Avatar
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 1,573
Images: 5
Hmm it must be fused - tbh I'm just not sure where!!
JR Racing is offline  
Status: -
Join Date: Apr 2009
Location: United Kingdom
County: Derbyshire
Posts: 6

Member car:

Alfa Romeo GTV

I replaced mine and blew the fuse by wiring it up wrong - resulting in the radio not working. Replace the fuse for the radio and the aerial worked as it should. Can't remember what the fuse number is off hand but it's on the main fuse board in the drivers footwell. Dig out your manual it's listed there with location and fuse size.
adam125 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

aerial , electric , fused

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome