Whining Noise: What is this next to the battery? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 29-06-09 Thread Starter
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: Greater London
Posts: 53
Hmmm Whining Noise: What is this next to the battery?

Hi All,

A couple of days ago this high pitched whining noise started only when the engine is running. It sounded electrical, like it was coming from the rear speakers but I have now tracked it down to the object in the picture attached which is to the left of the battery.

What is that?? Anyone else had this problem and how can I fix it?

I have a 2.0 TS Phase 2

Thanks in advance.
Attached Images
File Type: jpg P6290017.JPG (52.9 KB, 15 views)
billystar is offline  
Sponsored Links
Status: now got a scooby wrx as well
AO Member
67duetto's Avatar
Join Date: May 2007
Location: United Kingdom
County: North Yorkshire
Posts: 73
Looks like it's the fuel pump, which is fitted in the top of the tank. That would also explain high pitched whine if the motor is spinning like crazy trying to pump the fuel through. Can't really help with repair, but I guess replacement is the only option. Should get one easy enough from someone like Lancsbreaker or UKautosalvage.

Edit: I don't know if they are on this forum, but you track them down through alfa145.com
67duetto is offline  
Status: -
AO Silver Member
armoore's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Surrey
Posts: 3,690
It is the vapour separator. Part of the hydrocarbons emission control system. Fuel pump is part of the fuel level sensor in the tank (on most). Nearby is a solenoid valve which is in front of the vapour filter canister which is, in turn, next to the separator (to the left, follow the blue tubing). That might be your best bet for the buzzing sound if you had a V6. Alternatively on the TS the vapour canister may be under the nearside wheel arch and the solenoid is next to the inlet manifold so won't be the cause.

Last edited by armoore; 29-06-09 at 16:30.
armoore is offline  
Status: q2
AO Member
elm11g's Avatar
Join Date: Dec 2007
Location: Australia
County: New South Wales
Posts: 458

Member car:

2001 GTV 3.0 V6

i would also be interested if anyone has had any success in reducing / removing the whining sound,.. i do know there have been threads in the past, but no definite answer?
elm11g is offline  
Status: -
AO Member
jim3's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: West Yorkshire
Posts: 97
I had this when I first bought mine, and have heard similar on here. Never got to the bottom of it but a couple of specialists thought air in the pump. Hasn't done it since (3yrs).

jim3 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

battery , noise , whining

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome