Balancer Belt Grief Again!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Balancer Belt Grief Again!!

Had my cam belt plus balancer shaft belt plus tensioners changed at 52000 miles. The reason that I had them changed was that the engine was very rough at high revs (5000+ rpm). It turned out to be the balancer shaft belt belt - it was heavily worn in sections and had missing teeth/grooves. 12 thousand miles later and the car is suddenly exhibiting the same roughness. The roughness is intermittent - probably due to the balance shaft belt occasionally shifting into and out of its correct position.

Does anyone have any idea was would cause this. I cant believe it is happening again after so few miles. Maybe one of the wheels is sticking or something?? Having it checked out tomorrow by the garage. Please Help!!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

balancer , belt , grief

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome