Flat battery.........weird cause - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 17-06-09 Thread Starter
Status: -
AO Member
javars's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Somerset
Posts: 337
Cry Like A Baby Flat battery.........weird cause

Have suffered a flat battery twice in a week in my GTV 2.0. Nothing obvious, no boot light on, stereo off, no alarm fitted etc. Then I remembered, the other night the interior light stopped working, so I poked the buttons as you do and put it down to a failed bulb
Well, I removed the bulb and put a meter across it as it didnt look blown and it made a circuit. So I put 12v thro it from a battery & it didnt light
It turns out that it has failed to the point it wont light but it still makes a circuit and carries a current, and I'd left it switched on with my vigorous button presses
Anyone want to buy a used battery thats perfectly fine coz I aint taking the new (unessesary) one out again My backs still killing me !!
javars is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

batteryweird , flat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome