Damn thing wont' start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Damn thing wont' start

I've a 1996 GTV and 9 times out of 10 when I turn the ignition key the yellow code lamp stays on and the thing won't start, if I keep on trying the key then after about the 10th try it will start. I've tried the master key and the same thing happens, I've changed the battery (after been advised to) and the same thing happens.

Anyone got any advise before I throw loads of cash at my local Alfa dealer in the hope they can cure it?

Sponsored Links
Status: - Update
Posts: n/a
The battery would have been my first suggestion too. The code system needs a good feed to allow ignition.

Next step (as its erratic) I guess is to check the earths and all connections to make sure they are secure.

Status: cornea come l'inferno
AO Silver Member
Hoygaard's Avatar
Join Date: Apr 2002
Location: Denmark
County: Kobenhavn
Posts: 4,156

Member car:

156 GTA SW

My best shot at it; have the immobilizer coil antenna exchanged.

Best wishes

Hoygaard is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

damn , start , thing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome