engine compression - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 12-06-09 Thread Starter
Status: -
AO Member
mick45672's Avatar
Join Date: Apr 2007
Location: Cirencester
County: -
Posts: 38
engine compression

hi guys
ok got a wierd problem all started when my rad started to leak never overheated it got a new rad than my tempreture guage started acting funny will read temp when engine sits at fast idle(1500-1800) at ordinary idle it shows half reading when driving it doesnt work at all
in the process of getting a new one (if alfas can ever find the one thats fitted cuz as all us alfa fans know what the book says is on our cars probably isnt whats acualy there)
anyways cut a long story short it seems theres a lot of pressure in my radiator circuit
so today just to have a check while changing the plugs i did a comprssion test on the engine wich showed 90psi across the board now that seems like its a little low to me though the engine has done 140k
first is that about right
and second any ideas about the temp gauge
mick45672 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

compression , engine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome