Have you guys expierenced this? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Have you guys expierenced this?

Hello people hope you are all ok,

Listen I came across a strange thing yesterday and I don't know how to solve it. I was driving around at about 2pm the outside temp was 33C I noticed the car was not accellerating as normal. At first I thought it was because of the AC unit but I turned it off and it didn't make all that much of a difference. In the evening I took out the car again and it seemed fine the temp was about 25C so I put it down to air flow. Would putting a sports air filter help this at all? Have any of you come across this at all?

Drive safe

Sponsored Links
Status: - Update
Posts: n/a

Could be a fault in the electronics of the airco anyway. Don't be surprised when u turn the airco off for example in an Alfa Romeo and it still would be running.
But if it is the air flow(cold air is more dense so it really makes a change) and you want to install an open racing air filter,make sure you install a tube that brings cold air to the car. I did that modification on a 33,first without cold air flow and then with,and it really makes a huge difference in performance. Ofcourse it wont help much when you are driving slow.
Forgive the poor English language but I am not British.
Status: - Update
Posts: n/a
Hi Alfadude,

Your English is ok I'm not from the uk either. Well what do you mean by the tube that brings the air to the car?

Drive Safe

Status: -
AO Member
Join Date: Apr 2002
Location: bath,uk
Posts: 121
mine did exactly the same yesterady.. really hot.. and that bloody aircon takes away about 20-30% of the power.. I think the aircon has an overrun.. because after I turned it off it took about 10 mins for the car to run again normally.

was really hot out side though about 28+
joe_90 is offline  
Status: - Update
Posts: n/a
Hi Carmelo,

Concerning the tube,I don't know the correct word in English but so I ll add a picture of that modification: http://members1.chello.nl/~p.g.m.giessen/john-3.JPG
There you will see below the airfilter a silver tube that brings in cold air into the airfilter.
I hope it helps.
Good luck

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

expierenced , guys

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome