Electric hood has stopped working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Electric hood has stopped working

I don't suppose the sun is going to shine anytime soon but it would be nice to get it fixed in time for this year's 2 days of summer.

Engine on, handbrake on, hood catches released - I press the button and nothing happens, no movement, no noise, nothing!

I have checked the fuses, seen the cable hasn't snapped and that's about the limit of my diagnostic abitity. Is the electric motor burned out?

Anyone else had problems with an electric hood?
Sponsored Links
Status: Lapping Mondello
AO Silver Member
Toad's Avatar
Join Date: Apr 2001
Location: Ireland
County: -
Posts: 1,831

Member car:

75 LE

Sorry for the slow reply.
You need to see where the fault lies.
Disconnesct the motor & use a multimeter to test the cable to see if power is reaching the motor. If it isn't the fault is electrical, If you do get power the motor is at fault.
let us know now you get on.

if you don't have a multimeter you could use a 12v bulb & some wire.
Toad is offline  
Status: - Update
Posts: n/a
The hood is diagnosable using Alfas examiner computer, go to a dealer and let them check it. I have only had faults with the micro switches on the hood and the cover release motor.
Status: -
AO Gold Member
Spiderman's Avatar
Join Date: Dec 2001
Location: United Kingdom
County: Bedfordshire
Posts: 8,688

Member car:

2007 Ford Focus!

Hi Numan,long time, no hear!Where ya been? [img]smilies/smile.gif[/img]
Spiderman is offline  
Status: - Update
Posts: n/a
Way too busy, you lot keep breaking your cars!!!!!!!!!!!!!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

electric , hood , stopped , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome