ALFA SPIDER 2000 Indicator Problem!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-05-09 Thread Starter
Status: -
Join Date: Apr 2008
Posts: 2

Member car:

Alfa spider

ALFA SPIDER 2000 Indicator Problem!!

Hopefully someone can help me as this is dangerous!
When i indicate to turn right or left both of my indicators flash at the same time (as in similar to hazard lights flashing).
The only thing is, sometimes the indicators can function normal for days and then do the hazard like flashing and then become normal again - Any ideas what this could be - PLEASE!!
alfabbc is offline  
Sponsored Links
Status: Bavarian
Admin Team
bobda's Avatar
Join Date: Jul 2002
County: -
Posts: 15,247
Images: 13

Member car:

Not a GT

Re: ALFA SPIDER 2000 Indicator Problem!!

Might be worth checking out the two posts you made previously on this subject. (ALFA SPIDER 2000 Indicator Problem!!)

Moved to GTV/Spider 916 section.
bobda is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2000 , alfa , indicator , problem , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome