Help please! GTV starting problems... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 10-05-09 Thread Starter
Status: -
Join Date: May 2008
Posts: 5

Member car:

Gtv 3.0 V6

Help please! GTV starting problems...

Hi All,

Having some trouble starting my 2000 GTV V6. Took it on a short drive today and left it for a couple of hours. Came back and it wouldn't start. Starter motor was spinning but just wouldn't fire up.

I noticed that all the warning lights (inc the code one and the injector) stayed on rather than flashing and going off. Could hear the fuel pump priming.

I walked home to get the brown master key but still no luck so called the RAC a call. Guy said the injectors weren't getting power so the car was immobilised and it didn't seem to be recognising the keys. Disconnected the battery but still no luck.

Towed me home and we tried again on the drive and all of a sudden it started to recognise the keys again and start. Seems to work intermittently...

Anyone got any ideas?? I've got a horrible feeling its going to be expensive! I do have all the keys and the Code card though.

Has anyone been to the Gonnella Brothers in Catford SE London recently? The RAC said they'd tow me there in the week.
nrm2 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2007
Posts: 41

Member car:

gtv v6

Re: Help please! GTV starting problems...

There should be a fault code stored if the injecter light stayed on .If you look on the site you will find the way to obtain the codes.
willi is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , problems , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome