GTV 98 Ignition coil problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-04-09 Thread Starter
Status: -
Join Date: Apr 2009
Location: United Kingdom
County: Norfolk
Posts: 1

Member car:

GTV 98

GTV 98 Ignition coil problem

My GTV 2.0 16v Twin Spark 1998 does not seem to have any power comming from its 4th cylinder plug to ingnition coil.

My mechanic is lost and so am I?

PS it has been tested with a Snap-On ECU machine - no codes given.

It seems to runs ok with the coil power wire down; however runs rough sometimes for no reason (the problem just cant seem to be replicated)!!

Any help would be very much appreciated.


Ben Bishop
bishben is offline  
Sponsored Links
Status: -
AO Member
itacarboy's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Herefordshire
Posts: 869
Re: GTV 98 Ignition coil problem

is it deff a cylender not fireing?

an airflow meter made mine misfire before.

probs not much help
itacarboy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

coil , gtv , ignition , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome