gtv engine squeal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 05-02-09 Thread Starter
Status: -
AO Member
Join Date: Feb 2009
Location: United Kingdom
County: Angus
Posts: 13
gtv engine squeal

Hi there hope u can help.
I have just bought a 1997 alfa gtv with a 2.0 ts engine. The problem i have is that when it starts from cold it idles a bit rough until heated up, no big problem apart from it can cut out before its warm but the main problem is when it heats up it has an awful squeal from the engine at idle. When you rev it up there is no noise only when it sits idling. It had a timing belt fitted 3000 miles ago because i found the receipt but as i have just bought it i dont know how long the noise has been there for. There is no mention of the variator being done on the receipt but from what i beleive that is more of a rattle than a squeal. Any help would be appreciated. Thanks in advance. Baz
forfarbaz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

engine , gtv , squeal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome